隔壁网
本帖最后由 hongluo2000 于 2018-12-19 21:50 编辑

nextcloud号称下一代私有云,目前群晖的套件中心里还没有上架,只有owncloud,不过nextcloud各方面设计和体验感觉都要更出色些。功能比群晖自带的要强大不少的,还有各处插件可以安装使用。
下面就教大家来在群晖里安装,手把手教你们安装,仔细看

1、首先,确保群晖安装了 webstation套件,还有php7.0套件,phpmyadmin套件,数据库Mariadb10套件,套件怎么安装我就不多说了

360截图20181128182952025.jpg
360截图20181128183120290.jpg



2、下载nextcloud最新版,尽量下载稳定版,当然你也可以用最新测试版。
稳定版下载连接:   https://download.nextcloud.com/server/releases/nextcloud-14.0.4.zip     

3、 下载完成后解压出来nextcloud目录,并将这个目录上传到群晖的web目录下,然后ssh以root身份登陆群晖,需要修改所属用户和权限,所以要root身份, 更改nextcloud目录所属用户和组为http 并设置0755 权限, 这步很重要。

root身份登陆进入web目录后

chown -R http:http nextcloud      

chmod -R 0755  nextcloud


360截图20181128184243920.jpg 360截图20181128184853624.jpg

4、权限设置完成后,接下来就是进入webstation设置网站信息了,端口可以自己指定,外网访问要做好端口映射。 没有安装证书的,可以先用http端口
建议还是安装证书。如果不懂就直接按我下图来设置。php版本要选7.0,nextcloud不支持5.X的版本了,最少都是7.0了。


360截图20181128185151554.jpg 360截图20181128185316841.jpg

5、打开Phpmyadmin创建nextcloud需要的数据库,如果安装了MariaDB5和MariaDB10,建议选Mariadb10


360截图20181128190116478.jpg 360截图20181128190325184.jpg 360截图20181128190707198.jpg




6、上面的5个步骤都是准备工作, 下面就开始进行正式安装了, 打开浏览,输入你的群晖地址+端口,

比如我的   192.168.31.200:6680,即可进入下面的安装界面


未标题-1.jpg

这一步是最关键的,设置出问题的也比较多了,由于我们是使用MariaDB数据库的,这里就多说一点。群晖的MariaDB数据库端口是3307
另外数据库的账号和密码忘记的话,,可以在Mariadb套件里重新设置,可以在Mariadb套件里重新设置,可以在Mariadb套件里重新设置
重要的事说三遍。  连接地址是127.0.0.1:3307    然后点击安全完成。



如果一切顺利,成功后就会出现这个界面啦   
360截图20181128200243517.jpg 360截图20181128191017751.jpg 360截图20181219214943165.jpg





360截图20181128201254638.jpg
1

查看全部评分

分享到 :
7 人收藏

12 个回复

倒序浏览
muzil  高烧40℃ | 2018-12-2 20:44:39
shakayx  发烧38℃ | 2018-12-7 21:51:23
shakayx  发烧38℃ | 2018-12-7 22:21:28
yunlongwan  走火入魔 | 2018-12-8 00:11:10
shakayx  发烧38℃ | 2018-12-8 10:04:51
独孤残梦  正常36.8℃ | 2018-12-9 00:33:04
yfywk  高烧40℃ | 2018-12-22 11:32:58
shakayx 发表于 2018-12-7 22:21
请教一下。一切按教程来的。为什么出这样呢?

打开Web station ,PHP设置里面,PHP7.0选择了编辑,将里面的所有都选择,确定就可以了
E3672DAA-4116-49f1-9B0D-2F11E114A6C0.png
颓废青年  高烧40℃ | 2019-1-2 15:17:15
xiao3931362  高烧40℃ | 2019-1-11 22:35:16
到正式安装那一步, 打开浏览,输入我的的群晖地址+端口后,显示 Composer autoloader not found, unable to continue. Check the folder "3rdparty". Running "git submodule update --init" will initialize the git submodule that handles the subfolder "3rdparty".求告知哪一步错了
  收起(2)
您需要登录后才可以回帖 登录 | 注册

本版积分规则

微信扫一扫关注公众号,获取注册邀请码!

小黑屋|手机版|Archiver|隔壁网 ( 粤ICP备14056481号-1 )

Powered by Discuz! X3.3 © 2001-2016 Comsenz Inc.

返回顶部